Override rsync argument for remote interpreter

Hello,

I am using Rubymine with a remote interpreter. Problem is that gems in my interpreter's gem folder are symbolic link to my gem's remote host.

Rubymine using rsync without following links, it can't find the .gemspec of my remote gems, because the

ruby_stubs/1253485475/701060433/gems folder only contains broken symbolic link to my remote host . Example:

In my local Mac gem folder:

$> file memoist-0.15.0
memoist-0.15.0: broken symbolic link to /home/../TRUNCATED/build/ruby2.3.x/lib/ruby/gems/2.3.0/gems/memoist-0.15.0

So my question is, is there a workaround to tell RubyMine to override rsync arguments to follow symbolic links?

 

Thank you

1 comment

I had to disable the usage of rsync for remote interpreter:

Open Registry (Ctrl+Shift+A for me), and disable the value 'ide.remote.interpreters.use.rsync' value.

After gem were correctly synced and I was able to run/debug. However they were not showing in External Libraries, any idea why? All the gems are in my Gemfile.

0

Please sign in to leave a comment.