[solved] Project Interpreter Error: Please Specify a different SDK Name

On a project which has been working correctly for days I go into the Project Interpreter to remove a package and then, I get this error "Cannot Save Settings: Please Specify a different SDK Name"  I tried creating another virtual env and point to that but, same error. 

I have no idea why pycham is doing this. 

The selected Interpreter in the "Project Interpreter" field gets removed and the default <No Interpreter> setting is added.

Also, is a Django Project type and, it works fine from the command line. But, pyCharn is buggered cause No Python Interpreter is Configured for the Project.

 

PyCharm 2017.3.2 (Professional Edition)
Build #PY-173.4127.16, built on December 18, 2017
JRE: 1.8.0_152-release-1024-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.2

 

 

 

 

23 comments
Comment actions Permalink

I just had this issue and found that there was another environment with the same name.  Click "Show All" and click the minus icon on the environments you don't need or rename one of them so they don't conflict.

46
Comment actions Permalink

Your right, that worked

Thank you!

2
Comment actions Permalink

Any other ideas? I cannot create a virtual environment for my project, even with a unique name.

0
Comment actions Permalink

So I worked around this problem. I found two *existing* virtual environments with the same name (i.e. same as each other; not the same as the one I was trying to create). After deleting one of the two, I was able to create my new virtual environment.

5
Comment actions Permalink

Craigmjackson's tip worked for me too.Thanks!

The error message is definitely meaningful only to the programmer who wrote it. :-)

One thing I learned along the way: PyCharm caches your list of previously defined venvs *even if* you don't check "make available to other projects". I guess that makes sense now that I think about it, but it wasn't obvious at the outset.

 

0
Comment actions Permalink

I had the same problem as Dbattey - I had two virtual environments with the same name for another project.  Deleting one solved the problem.

I wouldn't expect there to be an issue with venvs with the same name as long as they're located in different locations.

0
Comment actions Permalink

Perfect, I had the same issue with PyCharm today.  Upon changing the spelling checker settings this issue showed up.  Very weird.

Thanks Craigmjackson!

0
Comment actions Permalink

Thank you it worked for there was two others with the same name i'm not sure what brought it up now but as always glad to ask 

0
Comment actions Permalink

Removing the environments with the same names worked for me as well

0
Comment actions Permalink

Thank you so much @Craigmjackson, that worked.

0
Comment actions Permalink

Thank you  @Craigmjackso from Korea!!

0
Comment actions Permalink

+1 to the OP, shesh.. was driving me nuts.

0
Comment actions Permalink

I just had the same problem but was pulling out my hair because the project I'm working on really and truly has only one virtual environment. But then I decided to see if OTHER projects have multiple virtual environments, and I found a project with two of the same. When I deleted the dupe, I was back in business.

0
Comment actions Permalink

Worked for me too! Make sure you erase ALL duplicate environments, not just for the one you're trying to use

0
Comment actions Permalink

I can not choose from project interprter any package, e.g. matplotlib

Everytime there is a an error: Error occured when installing package 'matplotlib'. Error occured: Non-zero-exit code

0
Comment actions Permalink

@Nurbek Halikulov

Please try the following:

- Try installing the package from the system terminal, using the same interpreter/environment (depending on which one you're using). Observe if you're receiving the same error. 

- Create a new project with a new virtual environment and try there.

- Create a new project with the system (global) interpreter and try installing there.

0
Comment actions Permalink

@Andrey Resler

 I did exactly what did you say.

When I choose settings--->Project: Nurbek--->Project Interpreter--->there are two packages, "pip" and "setuptools" packages are on the screen available. By clicking them, I can open the whole list of packages. When I install them, they are going correct. When I try other packages, always the same error. I click the top right + button and tried to choose any package, e.g. beautifulsoup4, matplotlib, etc. always the same error. 

 

I tried to create new project with a new virtual environment -- same error

I tried to create a new project with the system interpreter, unfortunately the same error.

Andrey is russian name? You can write in russian if you want. Thanks!

0
Comment actions Permalink

When I created a new project with a new environment, I did:

New environment using Virtualenv

Location: C:\\Users\Admin\PycharmProjects\untitled9\venv

Base interpreter:C:\\Users\Admin\AppData\Local\Programs\Python\Python37-32\python.exe

I even clicked to the buttons: <<inherit global site-packages>> and <<make available to all projects>> and created.

 

Result is the same((

0
Comment actions Permalink

I prefer to write in English, so that other english-speaking users could read that information in case they will face the same issue.

I was asking to do a test directly with the interpreter outside of IDE because there's a high chance the issue is not related to IDE, but rather to your python environment / pip . 

If that is the case, you may find better help on Stackoveflow or other Python communities.

 

0
Comment actions Permalink

Hey, I was having this same issue. 

Turns out, while the project I was working on did not have another Project Interpreter of the same name, there was a different, older Project Interpreter that appeared twice in the "show all" interpreters dialog. When I removed the duplicate (which was unrelated to the project I was working on), the issue was resolved. 

This issue popped up for me just after updating from PyCharm 2018.3 to 2019.1. Possible the duplicate interpreter name popped up as a result of that update. Fixed now. 

NO DUPLICATE INTERPRETER NAMES!!! lol ✌🏾

0
Comment actions Permalink

Delete all invalid virtualenv

0

Please sign in to leave a comment.