[solved] Project Interpreter Error: Please Specify a different SDK Name

On a project which has been working correctly for days I go into the Project Interpreter to remove a package and then, I get this error "Cannot Save Settings: Please Specify a different SDK Name"  I tried creating another virtual env and point to that but, same error. 

I have no idea why pycham is doing this. 

The selected Interpreter in the "Project Interpreter" field gets removed and the default <No Interpreter> setting is added.

Also, is a Django Project type and, it works fine from the command line. But, pyCharn is buggered cause No Python Interpreter is Configured for the Project.

 

PyCharm 2017.3.2 (Professional Edition)
Build #PY-173.4127.16, built on December 18, 2017
JRE: 1.8.0_152-release-1024-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.2

 

 

 

 

16 comments

I just had this issue and found that there was another environment with the same name.  Click "Show All" and click the minus icon on the environments you don't need or rename one of them so they don't conflict.

27

Your right, that worked

Thank you!

1

Any other ideas? I cannot create a virtual environment for my project, even with a unique name.

0

So I worked around this problem. I found two *existing* virtual environments with the same name (i.e. same as each other; not the same as the one I was trying to create). After deleting one of the two, I was able to create my new virtual environment.

2

Craigmjackson's tip worked for me too.Thanks!

The error message is definitely meaningful only to the programmer who wrote it. :-)

One thing I learned along the way: PyCharm caches your list of previously defined venvs *even if* you don't check "make available to other projects". I guess that makes sense now that I think about it, but it wasn't obvious at the outset.

 

0

I had the same problem as Dbattey - I had two virtual environments with the same name for another project.  Deleting one solved the problem.

I wouldn't expect there to be an issue with venvs with the same name as long as they're located in different locations.

0

Perfect, I had the same issue with PyCharm today.  Upon changing the spelling checker settings this issue showed up.  Very weird.

Thanks Craigmjackson!

0

Thank you it worked for there was two others with the same name i'm not sure what brought it up now but as always glad to ask 

0

Removing the environments with the same names worked for me as well

0

+1 to the OP, shesh.. was driving me nuts.

0

I just had the same problem but was pulling out my hair because the project I'm working on really and truly has only one virtual environment. But then I decided to see if OTHER projects have multiple virtual environments, and I found a project with two of the same. When I deleted the dupe, I was back in business.

0

Worked for me too! Make sure you erase ALL duplicate environments, not just for the one you're trying to use

0

Please sign in to leave a comment.