Use "public" modifier TypeScript issues

I am having trouble with a setting in WebStorm not working and I thought I would ask if I am missing something here before posting a bug.

In settings under Editor > Code Style > TypeScript > Code Generation I have checked the option Use 'public' modifier. If I then save that and go back to a class, hit Ctrl + I to implement missing members (in this case from an interface) select the members I want and hit enter. The methods are then generated without the public modifier.

I have looked through the docs and found https://www.jetbrains.com/help/webstorm/code-style-typescript.html#d179268e590 which is how I would have expected that setting to work. 

If there is something that I am missing, or this is a known bug, please let me know.

1 comment

https://youtrack.jetbrains.com/issue/WEB-29913 is fixed in 2018.1.

For now, please, use 'Implement all members' quick fix (available on Alt+Enter) - it works as expected

 

0

Please sign in to leave a comment.