Some shortcuts seem to be ignored

I've got a vanilla install of WebStorm (I'm a new convert and still learning my way around it) but I'm finding some shortcuts are being ignored or processed in an unusual way.

For example I've just discovered Emmet. Tab expansion works fine but the Shift-Alt-Open Bracket shortcut opens the version control tab (shortcut Alt-9) rather than goes to the previous Emmet edit point as it should. The Shift-Alt-Close Bracket shortcut is completely ignored. Both actions work if selected through the navigate menu though so Emmet seems to be working fine.

 

Any ideas?

9 comments

What OS are you on? What is your system keyboard layout?

0

Windows 10 with an English UK keyboard layout.

I wondered if it might be the Shift+Alt combination that was the problem but Shift+Alt+C brings up the recent changes dialog as expected.

0

Strange... From your description it looks like the wrong key codes are returned, but this shouldn't happen with EN keyboard layout and input language... Such issues usually occur when using no-QWERTY layouts or with non-EN input language

0

Some success, I suspect it's a Java issue..

WebStorm is running: 1.8.0_152-release-1024-b8

NetBeans (see below) is running: 1.8.0_141-b15

I'm not sure where to report this now? This isn't conclusive proof but I don't have time to develop an example showing the bug. It would probably stand a better chance of being addressed if an error report came from someone at IntelliJ as well.

Thanks for the help.

Testing

I wondered what would happen if I tried to re-enter the shortcut for the Emmet next edit point to "Shift-Alt-(" and WebStrom showed "Alt-Shift-9" which it seems to think is equivalent to just "Alt-9" (which is assigned to Version Control.

That got me wondering if it was a computer wide problem or just WebStorm. Word appears to correctly interpret the shortcut as "Atl+(". I assume this is the key combination that would be used since I'd expect shirt to modify the 9 before the alt is applied.

So next I tried it in an old version of NetBeans and I got the same incorrect behaviours as in WebStorm

0

Oh... After re-reading your comments, I see what's wrong now. The `Shift-Alt-Open Bracket` shortcut is `Shift-Alt-{`, not `Shift-Alt-(` - the bracket here is a curly bracket, not the round one.

0

Ah, an easy place to get confused. I call { an opening brace, it would probably be better if WebStorm showed the character if it was printable.

I'm not convinced Emmet is working correctly though. I expected it to work like this but when I step though edit points it only goes to the three indicated in the image below. Basically it's only switching between empty lines and the first angular component.

Thanks for your help.

0

as far as i can see from https://code.google.com/archive/p/zen-coding/wikis/Actions.wiki#Go_to_Next%2FPrevious_Edit_Point, edit points are points between tags, empty attributes and empty lines. And it works this way for me: for code like in https://docs.emmet.io/actions/go-to-edit-point/, I'm getting similar results. Where else would you expect it to stop in your snippet?

0

I see. I expected it to skip to the start of each attribute and just inside each tag regardless of whether there was content e.g. all the points you'd generally edit.

The two snippets of html below will produce the same output but the first has two extra edit points between the ul and li which could be useful for adding additional list elements at the start / end.

<ul><li><span class="">Foo</span>Bar</li></ul>

<ul>
<li><span class="">Foo</span>Bar</li>
</ul>
0

I see; it's not expected to stop in non-empty tags

0

Please sign in to leave a comment.