PHPStorm stuck on 'Waiting for "Scanning" to complete'

Hello, I am on the current version of PHPStorm (2023.1.2) and ever since the previous version I have had an issue with indexing being stuck on the message 'Waiting for "Scanning" to complete'. I have no plugins installed and enabled other than ones bundled with the IDE. I have tried uninstalling and reinstalling, invalidating caches and restarting, and repairing the IDE but none of these measures have worked. Any help will be appreciated as this is currently affecting my ability to search files and terms, perform commit checks, and is affecting performance.


As a test, could you please install 2022.3 alongside the current version and confirm that the issue is not reproducible there?


Hi Eugene, I can confirm after installing version 2022.3.3 this issue is not present. Additionally, it seems to have also disappeared from the 2023.1.2 version but I am not sure whether this is a permanent fix or if it is intermittent.

Edit: The problem has reoccurred on the most recent version of phpstorm. 2022.3.3 is still unaffected however.


If it happens again on 2023.1, please launch 2022.3 alongside 2023.1 and check if the issue is also present there, just as a test.
Then, please let 2023.1 hang in this state for a couple of minutes, and then upload the logs (Help | Collect Logs and Diagnostic Data) here:


Please sign in to leave a comment.