How to fix blurry UI when enabled fractional scaling?


Hello. I am using WebStorm for a few years. Actually I can say that I learned coding on it. I do not want to migrate to any other IDE. I bought a laptop that has 2520x1680 resulotion. I enabled fractional scaling to 150%, I am using Fedora 38. WebStorm does not scale itself, UI is blurry. How can I fix this?

I tried to add this to vm options, but it didn't work:


As I learned from Googling, WebStorm does not support Wayland. Is there a way to get rid of the blurry except of switching to Xorg? Because I tried and Xorg was problematic. 


WebStorm 2023.2
Build #WS-232.8660.143, built on July 21, 2023
Licensed to Ersin ....
Subscription is active until July 24, 2024.
For educational use only.
Runtime version: 17.0.7+7-b1000.6 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.4.4-200.fc38.x86_64
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 16

Non-Bundled Plugins: (232.8660.158)
    dev.blachut.svelte.lang (232.8660.129)

Current Desktop: GNOME

1 comment

ersinware until the native wayland support is implemented in our runtime I'm afraid there's nothing you can do except choosing non-fractional scaling or switching to xorg, please see this comment for more details.

Wayland project is currently under development, you can follow JBR-3206 to get notified about the progress. If you are not familiar with YouTrack please refer to this article.


Please sign in to leave a comment.