Project Structure Disappears Upon Opening IDE

Answered

My project structure is constantly disappearing from the navigation menu on the left. I do not know what is causing it. When I open a project folder, it shows up briefly, and then disappears. When I go to add a module under Project Structure -> Modules, it shows that one is already there, but all of the folder/file links on the right are red. If I re-add the root, it will resolve the issue, but then the next time I restart the project structure will be gone again. This is not a solution anyways because if I then try to reload my Maven project, the structure disappears anyways. I am on MacOS Ventura 13.2.1 with the Apple M2 Max chip. My IntelliJ version is "IntelliJ IDEA 2023.1.3".

I've already tried the following, multiple times:

  • Deleting the .idea folder
  • Invalidating IDE caches
  • Disabling all plugins
  • Resetting IntelliJ settings to their defaults
  • Reinstalling IntelliJ
  • Moving project location
  • Granting read/write permissions to the project folder and all files within

I also use WebStorm but this is not happening there. Does anyone have any idea what could possibly be causing this?

5
15 comments

Please try with IntelliJ IDEA 2023.2 release: https://www.jetbrains.com/idea/download/index.html.

If the issue persists, file a bug at https://youtrack.jetbrains.com/newIssue?project=IDEA and attach the logs (Help | Collect Logs and Diagnostic Data).

1

I am using intellij ultimate version 2023.2.3 and facing the exactly same issue for a long time. 
The same issue is not happening while using community version ( 2023.1.4)

0

Please report with the logs as described in the previous comment.

0

It's the same for me. Not only the project files are missing but also the terminal isn't working.
It happened after I moved the project directories around. 
After I deleted the .idea/ and rebuilt the project it seems working again.

Edit:
Unfortunately it breaks again the first time I run a file.

Edit:

For me the problem is closely related to the fact that the files are on iCloud. Is actually IntelliJ IDEA supposed to work even with files form iCloud?

 

0

I downloaded the latest version of IntelliJ and facing a similar issue. The project structure keeps disappearing from the navigation on the left menu. I have tried deleting the .idea folder, tried to add ‘Project Content’ but nothing seems to work.  

0

Please contact support at https://intellij-support.jetbrains.com/hc/requests/new and attach the logs (Help | Collect Logs and Diagnostic Data). Also attach .idea directory from the project and the screenshot of the IDE window when this issue occurs.

1

I downloaded the older version of IntelliJ - IntelliJ IDEA 2022.3.1 (Ultimate Edition) - and it worked fine. The new version of IntelliJ definitely has issues. 

0

Scott , did you found a solution? I didn't find the issue on youtracked

0

Hi Aurelie Giordano Please contact IntelliJ IDEA support for assistance directly at https://intellij-support.jetbrains.com/hc/en-us/requests/new and describe your case a bit more detailed. A couple of screenshots or a project sample could help with the investigation process

Possible workaround:

- File | Close Project

- Close the IDE

- Open a project root folder in the OS file manager

- Backup and delete the .idea folder and all .iml files

- Try to open a project in the IDE

0

hi Aurelie Giordano 

i got your notification, but i am not the “Scott” who posted this.  (weird)

more weird:  i have had this problem before, but i am not experiencing it now.  iirc, i deleted the project entirely (after making sure i had no outstanding changes) then checked out the whole thing via VCS again.

not sure if it is relevant but i am now using macOS 14.2.1 and IntelliJ 2023.3.3, which are slightly different than the “Scott” who posted this.

0

I too tore my hair apart with this issue for a while. Finally I realized that issue was happening when I did not use the Load Maven script option that comes up as a small pop up suggestion as soon as I import the Spring project. So when I didn't do it & ran the mvn clean install from the Run/Debug configuration it would not always load the modules & dependencies.

0

Hello.

I'm facing the same issue as OP, only I have a Scala project. 

To add, I'm able to use Community Edition without any issue. This only occurs with Ultimate.

https://youtrack.jetbrains.com/issue/IDEA-353756/Project-dissapearing

Can we get any updates, please?

0

Hi!

 

I'm facing the same issue. It keeps appearing and reappearing (my maven project.

 

Any Updates?

0
It's duplicated by https://youtrack.jetbrains.com/issue/IJPL-2152/IDEA-should-notify-users-on-macOS-if-there-is-no-access-to-the-directory-of-the-project-and-require-access , not fixed yet. Please try the workaround:
make sure IDE has permissions to access folders in System Settings | Privacy & Security | Files and Folders, see https://support.apple.com/guide/mac-help/control-access-to-files-and-folders-on-mac-mchld5a35146/mac for more info.
Another option is to move the project outside of Documents/Desktop/Downloads folders.
0

Jacky Liu Thank you for your response. The workaround did the job for me!

0

Please sign in to leave a comment.