Codeception integration can't find path to interpreter remote

Hey together,
I'm experiencing some problems configuring codeception for phpstorm using a remote (docker) interpreter.
it always shows me:
when trying to run it.
So I tried to fix it but my configuration seems to be correct as he finds the correct version for codeception?

does anyone have any idea?

Running on Mac Ventura and PhpStorm 2023.2.1 RC
But also didn't work on older, stable versions of PhpStorm.


Please share the following screenshots:

  • Settings | PHP
  • The interpreter properties after you click [...] next to the chosen interpreter at Settings | PHP
  • Settings | PHP | Test Frameworks

Thank you!


Hey Eugene,
thanks for the response.





Ah, I missed it - please use the absolute path for the Codeception executable instead of a relative one.


Already tried: /var/www/html/vendor/bin/codecept
according to the documentation:

it should be vendor/bin/codecept

Both show me that the executable was found but still produce the same error.


Please try removing the Test Framework configuration, closing the settings, and then adding the Test configuration back, using the absolute path now.

according to the documentation it should be vendor/bin/codecept

I don't really see any relative path mentioned on this page. Am I missing something?


This would be the part of the documentation:

Tried removing the test framework, closing it and adding it again.
Same problem sadly


Thank you for checking!
It might be something related to submodules. We have a similar issue with PHPUnit:
Do you think you could share a project sample with us? We don't need the actual sources, just the project structure including vendor, composer.json files, and a single failing test.

You can use our private uploading service to share it with us:


Also, as a workaround, please try to add “Main” test framework configuration for a local interpreter with the full path to codeception like “<your project path>/vendor/bin/codecept”. in this case test run even using remote interpreter should work fine


Sorry, totally forgot to answer.
I will talk to the company if I'm allowed to share that, but I think it should be possible :)

I'll try the workaround from ivan now.


Please sign in to leave a comment.