Installing plugins in JetBrains Fleet

Answered

Report this ad 18 Hey guys I was trying out Fleet and really liked it but I had a hard time configuring it. I wanted to install a plugin but I couldn't find an option to add plugin anywhere. Does anyone know how to install plugins in JetBrains Fleet?  TellTims Survey

2
8 comments
Could you please specify what plugin did you want to install? 

Adding plugins support in Fleet is one of the main priorities for us, but there is no ETA at the moment.
1

Hi. Long term Webstorm user here. I was looking for Fleet plugins too. NX plugins in particular.

https://plugins.jetbrains.com/plugin/21060-nx-console

1

Thank you for sharing your feedback, Rihdus Io! We getting close with plugins support and will release it very soon, hopefully. Stay tuned! Thanks.

2

I 4th this idea…!

I love the idea of fleet. IntelliJ takes such a load and boot time when I just want to view or do something simple. But being able to install (just the) lightweight plugins (i actually need) would convert me to actually using this product.  

It's currently all or nothing. Open IntelliJ IDEA and it's massive tool set, or this (pretty darn advanced 👏👍) text editor that is sooooo close to a lightweight alternative when you just need to do something quick or have a tiny project (like a set of scripts) where IntelliJ is overkill.

Plugin support would be a major selling point to convert.

0

@Andrey Dernov  that is good news - fleet is unusable until we can get plugins and get a Vim mode. However, no-one has stated yet whether or not the fleet plugins will be IDEA plugins - if plugin authors are going to have to rewrite all their plugins to support two different jetbrains interfaces that is going to be a real problem for all concerned. Are you able to confirm whether all the existing IDEA plugins will work?>

0

Hi Kean. Fleet and IntelliJ IDEA have very different architectures, thus it will not be possible to use in Fleet the plugin that was initially developed for IntelliJ.

0

That does make sense and comes as no surprise. Shimming is difficult and slow. I just hope and pray to the vi gods that Vim compatibility is one of your first plugins :) Thank you for the update - I am very much looking forward to playing with Fleet when I can drive it properly.

0

We are indeed working on better Vim support. Feel free to try the current Vim support in Fleet and provide your feedback here 

FL-10664 Vim mode/plugin 

Where you can also see the current progress.

0

Please sign in to leave a comment.