Stop removing blank line

Answered

Hello,

I have a problem on GoLand (that I don't have on other PyCharm, CLion, Intellij...) I can't leave blank lines for 3 seconds (on auto save), the IDE deletes them directly which drives me crazy and I've just spent 2 hours in the settings but I can't find anything to deactivate it.

Please help me

0
3 comments

Hi,

Does it help if you disable Settings | Tools | Actions on Save | Reformat code?

1

Thanks indeed, it doesn't take away any more lines before I have time to write!

But now I have another problem, at the end when I Reformat code it changes all the tabs (4 spaces) by the tab character while everywhere in the settings I have unchecked Use tab character.

Does anyone know why?

0

Most likely you also should disable Run gofmt on code reformat via Settings | Editor | Code Style | Go | Other.

1

Please sign in to leave a comment.