webstorm ignoring noUnusedLocals and noUnusedParameters in inspections


I am running the latest webstorm and typescript. I have eslint rule enabled

"@typescript-eslint/no-unused-vars": “warn” 

I also have in mytsconfig

"noUnusedLocals": false,                /* Report errors on unused locals. */
"noUnusedParameters": false,            /* Report errors on unused parameters. */

For some reason I get multiple warnings on unused parameters and locals like this.

TS6133: 'req' is declared but its value is never read.

How do I turn these off?


thank you


Most probably the file the errors are reported against is not included in this tsconfig.json 

The built-in compiler service uses the nearest tsconfig.*.json file the current *.ts file is included in to report the errors, traversing the folders tree up to the project root. tsconfig.*.json here is a file with a name matching one of the patterns configured in Settings | Editor | File Types | TypeScript Config file type. If the file is not included in any configs, the IDE uses default settings obtained by sending a standard SetCompilerOptionsForInferredProjects command to tsserver


no, that's not it. The file type is there and the tsconfig is being used, if i change other options in the tsconfig they are reflected immediatly in the project. It is only this option that reports warnings.

It worked fine until this latest release of webstorm, so something has changed. I never got these warnings prior.




Ah, got it! these are not errors but suggestions , they aren't suppressed by

"noUnusedLocals": false,
"noUnusedParameters": false

These suggestions have always been there, but they were not highlighted in editor until the recent fix (please see Optionally highlight suggestions from Typescript language service in editor)
We have a feature request for a possibility to suppress them, Opportunity to turn off optional TypeScript service inspections. It's fixed in 2023.2.2 update


ah, ok, cool, I will wait for the fix. thank you.


Please sign in to leave a comment.