Syntax highlighting randomly stops working since last update (2023.2.1)

Hi there!

I'm struggling to find out why syntax highlighting stops working every time I start PyCharm since I updated it to 2023.2.1. It works just fine for a couple of minutes, then it just stops highlighting new code. I have the hiberbee theme installed, but I tried with the default themes and some others, same issue. Using the new UI with Windows, running Python via wsl. 

Thanks so much!



I have the same issue, any new lines of code written do not have syntax highlighting unless the IDE is restarted, problem started in version 2023.2.1




First of all, please disable all custom plugins, go to **File | Settings | Plugins** click the gear icon and choose "Disable all downloaded plugins", to avoid third-party affection.


If it does not help, please upload  logs folder zipped from ***Help | Collect logs and Diagnostic Data***  to the FTP and please let me know the filename.


Hi Demeter, where you able to figure out the issue? I'm having the same issue. It's frustrating


Antonina Belianskaya Hello, I am facing the same issue.

Is this a known issue in the latest version?


Demeter Turos  Are you using any speciffc third party libraries? Maybe its one of the libraries causing the crash.


Let me know if you are, maybe we can find out which one is in common between us


Antonina Belianskaya  The issue is not resolved by turning off custom plugins. Also created a new project to test it but no luck. Here is the ID of the diagnostics file: 2023_09_27_xfnJUELPwVuoJxAKnJeskX 

Thanks for looking into this!


@Demeter Turos please  attach a screenshot of the Project Interpreter settings. 

As a matter of test, please try to start IDE with default settings as described here


Will it make any difference? 




I tried resetting to default settings. So all plugins were removed and the IDE appearance was changed to the new more recent interface. However the problem persists and syntax highlighting initially works then stops updating. For instance I type lines of code and there is no syntax highlighting. If i restart the IDE, pycharm correctly highlights code, but new additional code written or a new file opened, after a certain amount of time, syntax highlighting stops updating.


I've uploaded my diagnostic logs: pycharm-logs-20231012-1342527946878177698605726, let me know if there is anyway to resolve this?


Gareth Egerton


please share the upload ID, with the provided file name I cannot find it. 


I've just uploaded new logs here: Upload id: 2023_10_13_5inp8fyHnGnVMcN8ts8W6k (file:

And the previous: 

Upload id: 2023_10_13_DwBTQDHzHhebriuzfS4umk (file:

Would appreciate if this could be looked at urgently as currently I need to restart pycharm approximately every 7 mins  (the time it takes on average for syntax highlighting to stop working). I've investigated and there doesn't seem to me to be an obvious trigger for this to occur other than how long pycharm has been running. Have tried amending my maximum heap size, but it was already set to 4gig and increasing it didn't appear to have any effect.

Also tried using the pre-release version 2023.3 but the problem also exists in this, so have reverted to the 2023.2 stable version.


Could you please (once again, please) disable all custom plugins, go to **File | Settings | Plugins** click the gear icon and choose "Disable all downloaded plugins", to avoid third-party affection - and upload a log where all plugins are disabled and the problem persists? 

Does it happen with python files or jupyter notebooks?  Am I right understanding that all files are located in WSL file system? 

Do you have any antivirus/farewall software installed? 


This happens with .py files. Yes all files are in WSL2 ubuntu.

I believe the virus protection is just windows 11 own protection and firewall.

I've disables all downloaded plugins, here is another log. After around 5 mins, new files open without proper syntax highlighting.

Upload id: 2023_10_13_6SqbeehkboFeUZ59a4z64V (file:


 As a matter of test, please try to disable the Qodana plugin. Will it make a difference?


May I ask you also to check the preliminary steps :

Please make sure all system updates are installed.


I did check other PyCharm versions as well, 2023.1.4 works just fine, and after installing, 2023.2.3 still had the same issue. 

However disabling the Qodana plugin as suggested by Antonina Belianskaya seems to have solved the issue for now (using 2023.2.3).


For my issue, I realised that my WSL2 disk space was running low, even though windows had a lot of space left. I cleaned this up and freed space and ever since I have not had the issue, so perhaps its related? This was on 2023.2.3.

In any case it would be good if pycharm could raise a warning if available disk space is not sufficient for it to run properly. Anyway, I can't be sure that this was the reason for the error, but it seems correlated.



Please sign in to leave a comment.