Git push Agent Forwarding request window stopped working after upgrading to 2023.2.1



I am connected to a remote machine through SSH. The SSH has agent forwarding enabled. There are no keys stored on remote machine.

When I want to push, PyCharm was asking me to load some keys, use agent forwarding (this time/while connected or sth).

But not anymore.
Now it asks for GitHub tokens or authentication. How can I get the old behavior back?

I tested, the agent forarding is working, even from pycharm's ssh console (the one that can be spawned before connecting to a remote development env) 

LE: When trying ssh -T  from the PyCharm's terminat (connected to the remote env) IT SHOWS the freakin agent forwarding window!!! And no, even if I select in that window to forward requests, when I do the push, it asks for github credentials.


JetBrains Client 2023.2.1
Build #JBC-232.9559.58, built on August 22, 2023
Runtime version: 17.0.8+7-b1000.8 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.2.0-32-generic
Controller in Remote Development (PY), direct control type: Lux
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 8

Non-Bundled Plugins:
   com.intellij.plugins.github.colorscheme (232.8660.88)
   com.intellij.plugins.warmneon.colorscheme (232.8660.142)
   com.intellij.plugins.twilight.colorscheme (232.8660.88)
   com.intellij.plugins.monokai.colorscheme (232.8660.88)

Current Desktop: ubuntu:GNOME


Apparently is project dependent. What settings is forcing PyCharm to use GitHub specific authentication and ignore other methods? And how can I override it?

Note that using remote operations from CLI git client works w/o any issues with agent forwarding. On the same project where PyCharm is failing. 

Tried same machine, same 2023.1.1 (reverted to older one to check), on initial project and I got the same GitHub window:


While I was expecting “classical” agent forwarding:

Thank you!



It looks like the name of remote is in https format for that project. Please go to: Manage remotes and change it to ssh. 

Will it work fine then? 


Wow! I looked at the origin address like 5 times and I MISSED the freakin' https! Big Thank You! 

Issue closed.


No problem, glad it worked out! 


Please sign in to leave a comment.