Prevent New UI main toolbar from hijacking OS window controls



while I think the current new UI looks sleek, is there a way to have set it up so that it ‘respects’ the operating systems appearance for windows and does not look out of place?

I am running linux. When I enable the new UI I am greeted with the “Welcome to IJ” window with project selection which looks completely normal. 

The project view is a different case though: the main top toolbar “hijacks” the window in order to display controls in the title bar itself. I get the idea but it makes the IDE look completely out of place in comparison to applications as suddenly I have a single application that has a different window style (dark title bar in light theme, different controls for minimizing/maximizing/closing window, ui element in the title bar).


The only related setting I would was whether I want to have the “main menu” expanded permanently or not.

Is there a setting for the new UI to use the new style inside the editor but not overwrite (I am assuming it is hiding the real title bar and painting the “custom one” inside of the window) the native window appearance?


From the 2023.2 release there are some major changes for window title bar in Linux. The custom header is turned on by default in New UI. There are some known issues related to this new feature: We are working on resolving them as soon as possible.

The only related setting I would was whether I want to have the “main menu” expanded permanently or not.

Not sure on which setting you are referring to, but as a workaround you can try turning back on the native window header. 
In Settings (Ctrl + Alt + S) > Appearance & Behavior > Appearance > UI Options > disable the option Merge main menu with window title.


The setting you are referring to is the one I have found but it does something different than what I am asking about. I have taken three screenshots, one with classic UI (1), one with new ui checkbox disabled (2) and one with the checkbox enabled (3).

My issue is that the native title bar, window controls and window border are hidden and replaced by the custom transparent border, transparent title bar and custom control inside the window. Note that the screenshots are not cropped “incorrectly” on top and both sides, I have taken screenshot of the “current window” in all three cases but in the cases of new UI the title bar and window border are made transparent which is why it includes desktop background.

It makes sense if you are replacing them with custom theme / controls but what I am asking is if there is or will be an option to disable this so that the application looks native, same as all other windows, as it does with the classic UI.





Sorry I have realized there are two settings regarding the main menu. One setting is called “show main menu in separate toolbar” which seems to to what I was asking about!

This now looks correct, although it being dark in a light theme is a bit off, but that is a completely different ‘problem’ than the one I was originally asking.

Thanks for pointing me in the right direction.


edit: I have realized there is a setting for it as well that needs to be specifically enabled (light theme with light header). Now everything looks fine!


Please sign in to leave a comment.