Only the main class that gets created recognizes java


If I make anymore classes, it stops reading that class as not java. I tried reinstalling but I'm stumped.


Hi Pluto4586 Does it help by using menu File | Repair IDE? 

If the problem still not fixed, please attach the logs via the menu Help > Collect logs and Diagnostic Data if possible.

If you can't send files by mail, please upload it to and paste the upload id here.


Hello, I tried repair IDE and it seems work for a second off bootup, the IDE is ‘scanning files to index’ and after it does that it goes back to not working. Heres the upload ID and thank you for the help!


Upload id: 2023_09_21_SBDhndBafDn3Tg1iJj9qTr (file:



Hi Pluto4586, I've checked the log, you are using IDEA 2022.3.2, can you try the latest version IDEA CE 2023.2.2 to see if it helps? Indexing system has been improved a lot since 2022.3. If possible, please upload the project file(delete some sensitive source code or just .idea folder) to and paste the upload id here.


Again, no dice. Not sure what I can do, I re-installed a couple of times.

Upload id: 2023_09_26_22rbZ2EuuP2NRu1iEcAVBw (file:





Hi Pluto4586, if you are talking about file, then there is a problem within the code: method calls must be in a method or under a variable def:

public class Main {

    public static void main(String[] args) {

If this is not your case, please let me know.


Please sign in to leave a comment.