Run Window Caret/Cursor Positioning


I have observed this on CLion 2023.1.4 Build #CL-231.9161.40, built on June 20, 2023. I have Windows 10 Home, 22H2.

Imagine that I have a program that outputs statements to stdout and reads from stdin (especially, the C++ cin.ignore function call). I run my program (Ctrl+Alt+F10 on WIndows) and it outputs to the Run Window (Alt+4). However, I have observed that the scroll-bar first hits the top, rather than the bottom. This means, unless I press a key, my cursor/caret is not visible in it. 

Is there a setting that controls this behavior (sorry, I couldn't find it on Run Window's gear icon).

See, for instance, the entire view of my Run Window. You can perhaps see that it is waiting for something to appear on stdin, but I have no clue because I don't see the caret. The scroll-bar on the right displays the stickiness.


Thank you! It seems to help, although reproducing this bug consistently is a challenge. 

Thanks for the hint, again!


Please sign in to leave a comment.