Forums don't work in Firefox


The signin for forums does not come up in Firefox. Please fix. It's a very bad idea to force people to use Chrome.


Hello Ccleveland ,

For me “sing in” works fine in Firefox. Can you please provide additional information: 

- Firefox version

- error message/screenshot


When I click the “SIGN IN” button in the upper right corner, it refreshes the support page ("How can we help?"). It does not bring up the sign in page. No error message.


Please try to disable browser extensions, clear browser cache and cookies, check that you use the latest version of Firefox.

If it doesn't help, make a short record which represents the issue and share it with us (you can upload the video to and share the upload ID)


I use Firefox 117.0.1 on Windows 11 22H2 and am able to log into the forum with my JetBrains account. Also my account needs a more complicated 2FA login and it still works. To investigate your issue I propose to look into the logs of the session by pressing F12 and going into the Console tab in your Firefox.


Just tried again after upgraded my Firefox into the latest version 118.0 and it works properly as well.


I was also getting this problem with the forums. I had to turn off “Enhanced Tracking Protection” to get the login to work


Same problem here. FF 118.0.1 , macOS 10.15.7. Daniel Heard 's solution worked for me - thanks!

From Firefox settings: Heads up! This setting may cause some websites to not display content or work correctly. If a site seems broken, you may want to turn off tracking protection for that site to load all content. Learn how


Please sign in to leave a comment.