RubyMine can't find my asdf rubies installed in WSL on remote connection

Hi, I've been trying to use RubyMine on Windows 11 with WSL and I've getting frustraded on the proccess, mainly because the fact I cannot use a remote Ruby interpreter on WSL remote connection. Neither with a Ruby interpreter nor with a version manager (any of them, asdf, rvm, rbenv). It says that there are no rubies installed on my WSL machine. I've been trying of many different ways, and none of them is getting successed. Here are some of screenshots showing my problem:



I'm using the New UI and the last version of RubyMine, 2023.2.3, Build #RM-232.10072.21. But I've been facing this issue for 3 or 4 months. I've already tried other Linux distribution on the WSL, like Ubuntu, and other version managers like rvm and rbenv, but I faced the same issue.

1 comment


Have you tried with other distributions? I was checking it with Ubuntu and rvm, and it worked fine, need some time to re-check with Arch. 


Please sign in to leave a comment.