Goland: Every few seconds the code expands

Answered

Hello everyone

On MacOS and Goland, my GO code auto expands every few seconds.

It is so annoying, it interrupts my focus and sometimes I work accidentally in another function due to the suddenly expanded code.

This issue is recognised as a bug. The ticket were closed and I were relayed to another (older ticket) that has only a “normal” priority. Sad part to me is, that the ticket is more than 5 months old.

However, this issue is in my opinion so intense, that I can not use the IDE (that I paid for).

It doesn't matter if I the latest stable version or the current EAP. How is it possible, that this problem has not a high prio? 

Has anyone else worked with fully collapsed code … it's pita..
 

0
2 comments

Hi Stephan,

Sorry for the inconvenience.

Could you please try to disable Reformat Code and Optimize Imports in Settings | Tools | Actions on Save?

1

Hello Daniil 

This did the trick. No freaky auto expand, such a relief.

0

Please sign in to leave a comment.