ProcessCanceledException when debugging, despite -Didea.ProcessCanceledException=disabled


I ama aware that this is kind of a duplicate question: During plugin development, debugging gets interrupted by ProcessCanceledException. I have read that adding “-Didea.ProcessCanceledException=disabled” as a VM option will disable it.

This doesn't work for me. As you can see below, I use the gradle task runIde with the respective property:


IntelliJ IDEA 2023.2 (Community Edition)
Build #IC-232.8660.185, built on July 26, 2023
Runtime version: 17.0.7+7-b1000.6 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11.0
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 20

Non-Bundled Plugins:
   com.jetbrains.test.robot-server-plugin (0.11.20)
   com.lasagnerd.odin (0.2.0)

Kotlin: 232-1.9.0-IJ8660.185


I assume that these actions should be executed on the IDE being debugged, is that correct? Is there a way to enable this at startup via a system property or similar? Something like the -Didea.ProcessCanceledException=disabled from the original question.


Hi Colin,

Yes, it should be enabled in the IDE development instance. It is not persisted, and I don't see an option of enabling it forever, which is, IMHO, good, as it should be enabled only for debugging specific issues, where thrown PCE doesn't allow to inspect the execution flow slowly. Enabling it forever could cause IDE freezes, which would be bad even in development instance.


Thank, you! I guess this is the answer for now. For debugging - e.g. completion contributors - it may be a useful to start the IDE with disabled PCE. 


Karol Lewandowski After enabling “Skip Window Events” I still get PCE while debugging. I think they are less frequent compared to “Skip Window Events” OFF, but not entirely sure


Hi Antonino,

Are you able to identify in what cases it is not disabled? If you are able to identify it, please report a bug on


Please sign in to leave a comment.