Disable auto semicolon insertion

Answered

I have disabled all auto code insertion that I can find in the settings. However, I still get semicolons appended to the line as I'm typing. For example:

I have this line and my caret (displayed as a pipe in these examples) is at the end of the line.

List<Foo> children = source.getList("bars", Bar.class).stream()|

As I type in a dot, a semicolon as appended after the caret.

List<Foo> children = source.getList("bars", Bar.class).stream().|;

The same thing happens if I position the caret in getList and type. A semicolon is appended at the end. Under some circurmstances it will add a semicolon for each character I type resulting in ;;;;;;;;;; which I have to then fix.

Ultimately I want no auto insertion/typing/completion except:

  • If I open code completion and select an entry;
  • Import insertion, and clean-up on save;
  • Formatting on save;
  • Smart line indentation.

How can I sort this out?

0
2 comments

Hi, this doesn't sound like default behavior.

Does the problem go away if you disable all of the non-bundled plugins and restart the IDE? File | Settings | Plugins | ⚙ | Disable all downloaded plugins

0

Thank you!! It is the Actionable plug-in doing it. Now I just have to work out how turn off that feature.

0

Please sign in to leave a comment.