[SOLVED] Replacing German Umlaut

Good morning!

I work for few weeks with PhpStorm and I have a question about German Umlauts.

I wrote umlauts actually with ö oder ü or ß, but after I restart PhpStorm I get the original umlaut.

My project deploys my code directly to a FTP server that is configured with UTF-8. My IDE as well as my project is configured with UTF-8.

Does anyone have any idea why this is happening?


Could you please check if it also happens in a new empty project?
If not, please check at what stage the umlaut gets replaced - on save, on upload?


Eugene Morozov I have forgotton one elemental information. I work on a Zorin OS (Linux), not on a Windows.

So I have checked an example with different programs to compare and locate the problem.

* First the file which is stored local with Gedit =>

* Second the file on my server with VIM =>

* Third the file with PhpStorm =>

In my opinion PhpStorm has the problem



Please show what you have at “Settings/Preferences | Editor | General | Code Folding

IMO this can be “XML entities” under “XML” section.


Good morning,

this config you mean?


this config you mean?

Yes. Disable “XML entities” and restart PhpStorm. Any better?


It seems to be working now! Thanks!!


Please sign in to leave a comment.