Gcc.Exe - Broken CLion

So I dont know what happen for the CLion to stop running any project, I created a new project to test if it was something with my current project but it gave me the same output.


"C:\Program Files\JetBrains\CLion 2023.2.2\bin\cmake\win\x64\bin\cmake.exe" -DCMAKE_BUILD_TYPE=Debug "-DCMAKE_MAKE_PROGRAM=C:/Program Files/JetBrains/CLion 2023.2.2/bin/ninja/win/x64/ninja.exe" -G Ninja -S C:\Users\Admin\CLionProjects\untitled5 -B C:\Users\Admin\CLionProjects\untitled5\cmake-build-debug
-- The C compiler identification is GNU 13.1.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - failed
-- Check for working C compiler: C:/Program Files/JetBrains/CLion 2023.2.2/bin/mingw/bin/gcc.exe
-- Check for working C compiler: C:/Program Files/JetBrains/CLion 2023.2.2/bin/mingw/bin/gcc.exe - broken
CMake Error at C:/Program Files/JetBrains/CLion 2023.2.2/bin/cmake/win/x64/share/cmake-3.26/Modules/CMakeTestCCompiler.cmake:67 (message):
 The C compiler

   "C:/Program Files/JetBrains/CLion 2023.2.2/bin/mingw/bin/gcc.exe"

 is not able to compile a simple test program.

 It fails with the following output:

   Change Dir: C:/Users/Admin/CLionProjects/untitled5/cmake-build-debug/CMakeFiles/CMakeScratch/TryCompile-6gdb5f
   Run Build Command(s):C:/Program Files/JetBrains/CLion 2023.2.2/bin/ninja/win/x64/ninja.exe -v cmTC_5b53d && [1/2] C:\PROGRA~1\JETBRA~1\CLION2~1.2\bin\mingw\bin\gcc.exe   -fdiagnostics-color=always -o CMakeFiles/cmTC_5b53d.dir/testCCompiler.c.obj -c C:/Users/Admin/CLionProjects/untitled5/cmake-build-debug/CMakeFiles/CMakeScratch/TryCompile-6gdb5f/testCCompiler.c
   [2/2] cmd.exe /C "cd . && C:\PROGRA~1\JETBRA~1\CLION2~1.2\bin\mingw\bin\gcc.exe   CMakeFiles/cmTC_5b53d.dir/testCCompiler.c.obj -o cmTC_5b53d.exe -Wl,--out-implib,libcmTC_5b53d.dll.a -Wl,--major-image-version,0,--minor-image-version,0  -lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32 && cd ."
   FAILED: cmTC_5b53d.exe 
   cmd.exe /C "cd . && C:\PROGRA~1\JETBRA~1\CLION2~1.2\bin\mingw\bin\gcc.exe   CMakeFiles/cmTC_5b53d.dir/testCCompiler.c.obj -o cmTC_5b53d.exe -Wl,--out-implib,libcmTC_5b53d.dll.a -Wl,--major-image-version,0,--minor-image-version,0  -lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32 && cd ."
   ninja: build stopped: subcommand failed.


 CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
 CMakeLists.txt:2 (project)

-- Configuring incomplete, errors occurred!

[Previous CMake output restored: 28/11/2023 19:26]

I tried to reinstall CLion and it didnt worked. Any ideas how I can solve this?


Please sign in to leave a comment.