Vitest 1.0.0 - Test errors not getting reported

I had upgraded vitest to v1 yesterday and since then the test failures are not coming up when I run test using IDE (cmd+shift+R). To verify, I downgraded vitest and I was able to see the errors. There is no change in test configurations (vitest is correctly pointed to node_modules).

I ran the entire test suite in iTerm and webstorm. I can see error reports properly there. I had checked with my teammates who use IntelliJ and they report no such issue.

Here's one sample test I tried today with vitest 0.34.6:

Here's what I am getting after vitest upgrade to 1.0.0:

I thought to create issue in vitest but I see this is working in terminals and other IDEs. Please help me whether any extra configuration change is required or whether I should report this as an issue.

1 comment

Thank you for your help in providing all the details. We managed to reproduce the problem and have created a new ticket:

 Note that support for Vitest 1.0.0 will be available in IntelliJ / WebStorm 2023.3.1 (ETA: late December).


Please sign in to leave a comment.