Pycharm v2023.3 Python console doesn't provide access to variables

 

PyCharm 2023.3 (Professional Edition)
Build #PY-233.11799.259, built on December 3, 2023
Licensed to 3red Trading / Farouk Khawaja
Subscription is active until November 30, 2024.
Runtime version: 17.0.9+7-b1087.7 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 13.0
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 16
Metal Rendering is ON
Registry:
 debugger.new.tool.window.layout=true
 ide.experimental.ui=true
Non-Bundled Plugins:
 com.github.jk1.ytplugin (2023.1.64)
 ru.meanmail.plugin.requirements (2022.4.1)
 

Example.. the script ‘composer_fsk.py’ is super simple..

In older Pycharm v2023.1.4 which I was using, I could run this script using the pycharm script runner tool, then type ‘m.’ (m - dot) in the console and the console would display the available methods.   It no longer does this.  

Now, while the ‘m’ variable is there after running the script in the console, typing ‘m.' (m - dot) doesn't bring up the methods.   I can fully type them out myself and execute which works fine.   Is there a new configuration option that I'm missing or is this a bug?

The configuration of the script which is unchanged from the previous version of Pycharm.

2
5 comments

FYI.. I've run the script with and without the shebang shown in the script above.

0
Hi,

Thank you for contacting PyCharm support.

It looks like you faced a known issue: [PY-64055](https://youtrack.jetbrains.com/issue/PY-64055). Sorry for the inconvenience. Please vote for it in order to be updated on resolution.

----
Don't hesitate to ask if you have any other questions or require further assistance.

Kind regards,
Mikhail
[https://www.jetbrains.com](https://www.jetbrains.com) 
The Drive to Develop
0

Sorry.. seems hitting ‘enter’ in this text box publishes the comment.

In my case, the auto-completion options work fine.    

My problem occurs when I run a script and have flaged it to run in the console so I can interact with it.

As mentioned in the original post, when I run a simple script in the python console, I would expect that typing ‘m.’ would bring up the context menu for the variable.  It no longer does.   

0

Fkhawaja , please try setting Runtime under File | Settings > Build, Execution, Deployment > Console > Code completion

Does it work as expected then?

2

Thanks!  That solved the problem

0

Please sign in to leave a comment.