Constant "Scanning Files to index" -Pycharm 2023.3

Hi folks, IDE is “scanning files to index” forever and it hangs code completion/syntax checking.

PyCharm 2023.3 (Professional Edition)
Build #PY-233.11799.259, built on December 3, 2023
Licensed to Josir Gomes
Subscription is active until July 5, 2024.
Runtime version: 17.0.9+7-b1087.7 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 4.15.0-213-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 6144M
Cores: 12
Registry:
debugger.watches.in.variables=false
Non-Bundled Plugins:
 com.intellij.ideolog (203.0.30.0)
 net.seesharpsoft.intellij.plugins.csv (3.2.3-233)
 mobi.hsz.idea.gitignore (4.4.4)
 ru.meanmail.plugin.requirements (2022.4.1)
 com.intellij.bigdatatools.core (233.11799.267)
 com.intellij.bigdatatools.binary.files (233.11799.267)
 com.intellij.bigdatatools.rfs (233.11799.241)
Current Desktop: ubuntu:GNOME
 

2
10 comments

Similar problem when scanning for Packages list. See my post.

0

A similar situation. After updating to version 2023.3 the scan is constantly running. The scan is interrupted only if you open a pop-up window, such as the section about the program version

 

PyCharm 2023.3 (Professional Edition)
Build #PY-233.11799.259, built on December 3, 2023
Licensed to ……..
Subscription is active until October 9, 2024.
Runtime version: 17.0.9+7-b1087.7 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 5.15.0-89-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 8192M
Cores: 6
Registry:
 debugger.new.tool.window.layout=true
 ide.experimental.ui=true
 editor.minimap.enabled=true
Non-Bundled Plugins:
 ideanginx9 (0.1.9)
 com.jinsihou.react.snippets (1.1.1)
 com.github.copilot (1.3.0.3323)
 com.intellij.ideolog (222.2.0.0)
 name.kropp.intellij.makefile (233.11799.188)
 org.jetbrains.plugins.hocon (2023.1.0)
 dev.meanmail.plugin.nginx-intellij-plugin (2022.1.1)
 net.seesharpsoft.intellij.plugins.csv (3.2.3-233)
 ru.meanmail.plugin.requirements (2022.4.1)
 com.leinardi.pycharm.pylint (0.16.0)
 com.intellij.bigdatatools.core (233.11799.267)
 com.intellij.bigdatatools.kafka (233.11799.267)
 com.intellij.bigdatatools.binary.files (233.11799.267)
 com.intellij.bigdatatools.rfs (233.11799.267)
 com.intellij.bigdatatools.metastore.core (233.11799.267)
 com.intellij.bigdatatools.flink (233.11799.267)
 mobi.hsz.idea.gitignore (4.5.1)
 com.intellij.bigdatatools.spark (233.11799.267)
 com.intellij.bigdatatools.zeppelin (233.11799.267)
 com.intellij.bigdatatools (233.11799.267)
 com.intellij.plugins.html.instantEditing (233.11799.172)
Current Desktop: ubuntu:GNOME
 

0
Could you please report an issue to https://youtrack.jetbrains.com/issues/py and provide logs from **Help | Collect Logs and Diagnostic Data** after reproducing it?
0

Same issue here (Ubuntu from Snap channel). Going back to 2023.2.5 fixed the issue.

0

Hi Juanjo Alvarezmartinez could you provide the instructions on how to revert to 2023.2.5 ?

0

Well... I prefer to install via snap because it is integrated with Ubuntu and I can receive updates when you fix the problem. 

What I ask to Juanjo was: how can I downgrade using Snap?

0
I see, seems like a snap-specific question. Looks like you should select a specific channel to install from -- https://askubuntu.com/questions/1268615/snap-install-specific-old-version
0

I fixed the problem reinstalling the virtualenv. The problem is that I have about 30 virtualenv, one for each project…

I supposed that an IDE was a tool to save time… 

And to top it off, I still have to pay for it. lol

0

Josircg sudo snap refresh pycharm-professional --channel=2023.2/stable

1

Please sign in to leave a comment.