MSSQL: Import feature only imports 2000 rows


I have updated to the lates version of datagrip, 2023.3, and have tried using the new import feature, which i had to disable due to it erroring with a [S0001][1701] Line 1: Creating or altering table 'tbl' failed because the minimum row size would be 16014, including 8 bytes of internal overhead. This exceeds the maximum allowable table row size of 8060 bytes. Changing to the old import UI resolves this, however, the import will only import a maxmimum of 2000 rows. 
My previous version 2023.1.2 was fine, it would import all rows. I can't find a setting that is limiting this, but if any table has more than 2000 rows, only 2000 get imported. 

I am downgrading back to my old one since this is bit of a blocker for me. Can anyone point me in the right direction of why it's not importing a whole table? 


hi, I had the same experience. Exporting to a file and importing to the destination worked well (a little more of a hassle)

Hi Callum - I can't seem to reproduce the problem right away. 

Are you importing from MSSQL to MSSQL? How do you invoke the Import dialog exactly?

Please also provide:
1. The DDL of your table
2. idea.log collected after reproducing the issue: Help | Show Log in...

You can upload the log file privately to and share the id of the upload here.

Hey Arina, 

Yeah it's from MSSQL to MSSQL. Normally, I just drag one dbo on to the other DBO and just let it run. in 2023.1.3 it's fine and will import all rows for all tables. In 2023.3 it will only import maximum 2000 rows per table. 

2023_12_13_EPB9iPRWjQ5bdqzFNNUjrA ← Log and a table ddl for 2023.3

2023_12_13_nEU1qgRv8ahLNAdiDyuPje ← Log for my 2023.1

I have reverted back to 2023.1 for now since that works for importing all rows, and the old table merg ui doesn't throw that error in m post. 

Thank you. 

One last thing to confirm: do you use your database in single-user mode? Do you have the same problem with the import if you exit single-user mode?

I've tried both, single user it's 2k max, curiosuly turning that off it will do 10k max per table. 

Thank you. We will try to reproduce and fix this in scope of Please follow the progress there.

Please sign in to leave a comment.