reformatting .sh file doesn't do anything

Answered

Hi Folks. I finally migrated to the latest IDEA version, and I've noticed that the Reformat command does not do anything in a .sh file I have. It worked on older versions. Reformat works on a .py file, BTW. I tried both Reformat Code and Reformat File… with no luck. The attached pics show .py and .sh files before and after Reformat. Any advice would be awesome - IDEA is kind of my power-up when others at work need their files cleaned up :-)

# versions

IntelliJ IDEA 2023.3.2 (Ultimate Edition)
Build #IU-233.13135.103, built on December 20, 2023
Runtime version: 17.0.9+7-b1087.9 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 14.1.2
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 12
Metal Rendering is ON
Registry:
 debugger.watches.in.variables=false
 toolwindow.active.tab.contrast.background.color=255,255,255
Non-Bundled Plugins:
 com.andrewbrookins.wrap_to_column (1.8.0)
 Statistic (4.2.13)
 org.jetbrains.plugins.localization (233.11799.188)
 Pythonid (233.13135.103)
 net.ashald.envfile (3.4.1)
 R4Intellij (233.13135.65)
 ru.adelf.idea.dotenv (2023.3)
Kotlin: 233.13135.103-IJ

0

Please sign in to leave a comment.