Pycharm is not stopping on breakpoints in the unit tests - since PyCharm 2023.3.2 (Community Edition)


Since PyCharm 2023.3.2 (Community Edition) (Build #PC-233.13135.95, built on December 19, 2023) breakpoints are not working in the tests. 
Runtime version: 17.0.9+7-b1087.9 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Station: Apple M2 Pro macOS Sonoma 14.2.1 

I can debug and stop on break points in the code running from the main in the python files from anywhere, but it just doesn't stop in tests. Went through many similar issues from previous posts in Jetbrains tried everything but it just doesn't work. Tried to switch between “Module” to “Script path” in Run Configuration but no success.

Tried adding a new lines (print()) and set breakpoints on it, the code executed with the message printed in the console but pycharm doesn't stop on break points. Tried clean cache and restart and even we tried to do the same from another mac station. The problem persists.
Doesn't stop on exception (unless I set “On raise” on but it doesn't really useful)

I'm just getting tired of this for-no-reason memory heave and buggy IDE, time to move back to VSCode

0
4 comments

I'm sorry for the trouble being faced. Let's get additional details. Using a  local interpreter with that Python version?

Please provide us with a valid example where this behavior can be reproducible.

 



 

0

I have the same issue on both desktop and notebook.

PyCharm 2023.3.3

Python v. 3.12.1

pytest 8.0.1

0

Similar  for me, 

It seems to stop on the breakpoint in its flow, but does not reflect that in UI – so the process seem like "hanging".
If I remove all breakpoints – it goes through – but very slowish…

Seems it happens for tests involving odoo models setup – non-odoo ORM tests seem to work smooth.

PS: Same with `PYDEVD_USE_CYTHON=NO`
or removeing cython extention as here: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360010009979-Pycharm-2020-3-Debugger-is-not-working

 

Pycharm 2023.3.4 pro,  pydev debugger (build 233.14475.56)

as well as  7.4.4 (with pytest-odoo plugin v 1.0.0)

============================= test session starts ==============================
platform linux -- Python 3.10.13, pytest-7.4.4, pluggy-1.4.0 -- /home/jurgis/dev/monodoo/venv_siramis/bin/python
cachedir: .pytest_cache
rootdir: /home/jurgis/dev/monodoo
configfile: pytest.ini
plugins: odoo-1.0.0
collecting ... collected 1 item

0

Please sign in to leave a comment.