Cannot type any dead keys `~^'" in PyCharm

Hello,

I have a chromebook with python 3.9.2 and I have a keybinding problem with PyCharm. I am running developer mode and linux on the chromebook along with chromeOS. The following problem does not occur in any other program I am running, and I have checked the keyboard settings (US international).

In any program on my system, I can type the following key combinations to reproduce `~^'"

[`] + [space]

[shift] + [`] + [space]

[shift] + [6] + [space]

['] + [space]

[space]  + ['] + [space]

However, in PyCharm for some reason these key combinations do nothing. These are called dead keys because they are only displayed followed by another key (in this case [space]). From my understanding, PyCharm doesn't use dead keys, so I think that is where the problem lies. Every other key and key combination works fine, it is only these dead keys that do not function properly.

I have already tried looking up information in the keymap. However, when I try to define a new action as the combination [shift] + [6] (or any of the other combinations above without the [space]), then literally nothing happens. Any other combination besides these 5 works fine, for instance [shift]+[5] and [shift]+[7]. Does someone know how to fix this issue? Thank you for your time

1
3 comments

Hello,

Please open Settings | Keymap, click on the button on the screenshot, and try checking if the mentioned hotkeys are already assigned to different actions: 

0

Daniil Bogdanov IDK about the OP, but I have the same problem, and using the method you suggest above, I find no shortcuts defined for my dead keys.

It seems to be possible to define shortcuts for them, but what I need is not shortcuts for commands; I need to be able to type the characters mapped to dead keys.

EDIT: It may be relevant that I'm running PyCharm under WSL2.

0
If shortcuts conflict is not the case here, please create an issue on YouTrack so we can properly investigate it.
0

Please sign in to leave a comment.