PyCharm 'No Connection' while using JetBrains Gateway->Coder

Hi, I recently started using JetBrains Gateway to bring up a Coder workspace from which I run the PyCharm IDE on an mbp. Overnight, or at some interval, my IDE shows “No Connection." In VSCode, when the same thing happens, I can click that box and reconnect. With PyCharm, there is no obvious process. The editor panel also displays “No internet connection. Changes in the document might be lost. Trying to reconnect…” but, without any timeout interval, I'm not clear on whether something is actively trying to reconnect.

Also, even after re-authenticating/connecting Coder within the JetBrains Gateway, the last two times I've tried it, I then encountered a timeout when trying to load my installed IDEs (also in JetBrains Gateway), even though my workspace shows status “Ready.”  The only way to fix this seems to be to close the Jetbrains client and gateway and start from scratch.

Assuming my connection break is somewhat standard, is there a smarter way I should be managing it (directly in the UI, config options, speaking with my admin), or do I need to accept 5 minutes of rigamarole in restarting things each time this happens?

0
7 comments

Hello, 

What is the version of remote PyCharm?

0

PyCharm PY 2023.3.1.233.11799.298

JetBrains Client 2023.3.1
Build #JBC-233.11799.298, built on December 11, 2023
Licensed to <REDACTED>
Runtime version: 17.0.9+7-b1087.7 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 14.2.1
Controller in Remote Development (PY), direct control type: Lux
GC: G1 Young Generation, G1 Old Generation
Memory: 1504M
Cores: 12
Metal Rendering is ON
Registry:
 ide.experimental.ui=true
 rdclient.backend.actionHandlers=false
Non-Bundled Plugins:
 com.intellij.plugins.github.colorscheme (233.11799.172)
 com.intellij.plugins.warmneon.colorscheme (233.11799.188)
 com.intellij.plugins.twilight.colorscheme (233.11799.165)
 com.intellij.plugins.monokai.colorscheme (233.11799.165)
 

0

If you close the Client but not Gateway and click on the connection/provider again - does this restore the connected Client?

0

Closing the JetBrains Client closes the IDE. I want the IDE to remain open and to refresh the connection like in VSCode.

The source of the disconnect is possibly a VPN (GlobalProtect) disconnect overnight. I am expecting the IDE to reconnect with a single click, if not automatically on a retry cadence.

I did close the JetBrains Client, selecting “leave the backend running” (which I tried for the first time instead of terminating the backend) leaves me in the same state as above. I then can't start the client up again from the gateway, and need to close the gateway process/app and start from the beginning. If I don't restart the gateway, the “installed IDE" box never populates, it just hangs.

After closing everything, I can restart the client, and the IDE connects. Saying that this took five minutes was a bit of an exaggeration on my end, but this current workflow is very non-mac-like and non-jetbrains-like. I want to make sure I'm not missing a configuration setting or UI feature.
 

0

+1 For the ability to click on one of the buttons that shows up when the connection is severed to tell the IDE to reconnect, just like VsCode does.

My company's VPN times out quickly, intentionally, so this would be a big help.

I do see that the IDE will eventually reconnect, but there's a lag between re-establishing the VPN/SSH-connection and when the IDE responds. The button would help. 

0

I want to add that the JetBrains Gateway app, which always has to be restarted (quit and then re-opened) now sometimes has to be pkilled because I can't “Quit” it, or can't re-open it after quitting (OS-friendly killing) it, and the process continues to run. This has occurred three times.

ohearnt          24841   1.1  3.1 415555664 1046016   ??  S     9:59AM  15:37.45 /Applications/JetBrains Gateway.app/Contents/MacOS/gateway
ohearnt           3596   0.1  1.0 412135360 328016   ??  S     3Jan24  57:50.17 /Applications/JetBrains Toolbox.app/Contents/MacOS/jetbrains-toolbox --minimize

0

I spoke with the Coder team. Adding this entry to my host SSH file (and then restarted my connection) has solved the issue for two consecutive days:

Host coder-jetbrains--*
 ServerAliveInterval 5

This issue is resolved from my perspective

0

Please sign in to leave a comment.