Connection rejected to specific database, any way to ignore?

I'm using DataGrip to connect to databases hosted in Amazon RDS database servers.  I have recently run into a fatal error when trying to refresh the databases available on a particular server:

`[28000] FATAL: pg_hba.conf rejects connection for host <host>, user <user>, database "rdsadmin", SSL encryption.`

`rdsadmin` is a special, internal database AWS creates on each RDS server instance.  I don't actually want to access this database anyway.  Is there a way I can tell the DataGrip schema check to ignore this one?

The problem is that it it iterates over all the databases on the server in alphabetical order, but aborts the scan when it hits an error on this database.  As a result, I can see and query all databases that were scanned before `rdsadmin`, but none of those that would be scanned afterwards.  Since I *can* query the databases that get scanned (and “Test Connection” works), this tells me it is not a general authentication problem.


Hi, thanks for the report.

Please provide the following data for analysis:

  1. A screenshot of the data source connection dialog → ‘General’, ‘SSH/SSL’ tabs.
  2. The contents of your pg_hba.conf file.
  3. IDE logs (entire archive) collected after reproducing the issue: Help | Collect Logs & Diagnostic Data
  4. Introspection results: right-click on database name in the tree view → Diagnostics → Diagnostic Refresh

You can upload all of the files privately to and share the id of the upload here.


Uploaded as 2024_01_23_6ZQn2UnhZAwuPEaXXCzpMu (file:

Since this is RDS, I don't have access to pg_hba.conf or any other low-level PostgreSQL settings.  I only have what the web console and AWS CLI give me.

Thank you.
We received a similar report not long ago, so it could be a bug.

I submitted a new bug report about it to YouTrack: Developers will take a look and advise on the next steps.
You are welcome to follow the progress of the investigation there. I will monitor the issue too.

Thanks.  I wasn't sure if this was a bug or something I was missing in the UI.


Please sign in to leave a comment.