HiDPI scaling seems to have regressed in 2023.3.3 on Linux/X11/Plasma


The IDE scaling seems to have regressed in 2023.3.3 on Linux/X11/Plasma.

In the previous version 100% was entirely readable, but on this version 100% zoom is very small. I use a global scale of 137.5% in my KDE Plasma/X11 display configuration.

Version info:

IntelliJ IDEA 2023.3.3 (Ultimate Edition)
Build #IU-233.14015.106, built on January 25, 2024
Runtime version: 17.0.9+7-b1087.11 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.6.13-200.fc39.x86_64


Raman Gupta you might be facing IDEA-341318

Could you please check if adding -Dsun.java2d.uiScale.enabled=false to the file opened via Help | Edit custom VM options... solves the issue?

If not than please provide HiDPI info obtained as follows:

1. Run Find action in the IDE using Ctrl+Shift+A shortcut or Shift-Shift and switch to Actions tab.

2. Start typing “Show HiDPI info” and select the found action.

3. Make a screenshot of the appeared window and attach it to your reply.

It would also be helpful if you share the idea.log (locate it via main menu Help > Show log in [file explorer]). You can use our upload service for that, just let us know the upload ID. 

Thank you!


Thanks Ekaterina Valeeva – reading through the referenced issue, I noticed people were having the issue randomly, and indeed a restart with no other changes has “fixed” the problem on my system as well. Also using `-Dsun.java2d.uiScale.enabled=false` does not appear to cause any issues  It certainly seems like I might be running into that issue. Starred, thanks!


Please sign in to leave a comment.