how to change remotre python interpreter option

when trying to run debug with remote interpreter, the IDE generate the follwoing command:

.virtualenv/bin/python3.9 /root/.pycharm_helpers/pydev/ --multiprocess --client localhost --port 36199 --file /tmp/pycharm_project_907/

The client option has parameter “localhost”. On an old version of the IDE that parameter was “”

With the new IDE, run works fine but the debug fails with: “Could not connect to localhost: 36199”

So I want to change the option back to using, but in the run/debug configuration I could not find where to change this option. I could add “--client” to the parameter field but that just add it to the end of the command and debug still fails


I think the address is hardcode and cannot be changed. But maybe the issue can be solved on the host side? PyCharm uses SSH port forwarding, maybe it doesn't go through? 

You can test it with `ssh user@host -N -L 36199:localhost:36199`

Thanks for responding to my question, The ssh command succeds but since the port that pycharm uses is random every time, I can't not manually establish a port forwarding and let pycharm use that setup. 


Please sign in to leave a comment.