Android builds stopped working after latest upgrade



Everything was working fine this morning, I upgraded my IDE and went for a meeting, when I came back the android pluging seemed to have been uninstalled.   

After re-adding that, then upgrading all plugins etc… it still doesn't work.  

My build appears to succeed, but the run configurations say there is “no module selected”.   

Looking in the configurations show's there are no modules available at all.   

Creating a new project from scratch works, I can build and run it without issues. 

But my older projects no longer work, including an empty project (just one activity) I created just 10 minutes before I upgraded the IDE.   

I tried re-importing one of the projects but it didn't help.

Anyone got any ideas?  

I need to downgrade Intellij and see if I can get my projects working again. 



Is it possible to share your sample project (with just one activity) to check? How did you try to reimport project? Did you remove IDE related data (.idea folder and .iml file)?


I can share it on Monday. I tried deleting the idea folder, not sure about the .iml file, with no success. On my main company project I deleted the entire project and cloned it again from the git repo and that worked.  


The Android plugin may have been uninstalled during the IDE upgrade. Try reinstalling the plugin and re-importing your projects. If issues persist, consider downgrading IntelliJ for compatibility.


Please sign in to leave a comment.