Reformat on code customization for blade files


I'm using Actions On Save → Reformat Code, and I'm having this issue:

It reformats the <textarea> tags in my blade files, which results in rendering spaces before and after the text inside the textarea since it formats the textarea with newlines, it also adds spaces after {{ and before }}. The only solution I have found right now to fix this is to disable the formatting for blade files, which is not really a solution! Basically, I want when it encounters a textarea to skip the formatting. Is there any way where I can keep the blade formatting but disable the format of specific tags or parts of the code, or any other way to bypass/fix it? 

Thank you!


Hi Petros,

Would you mind sharing the file in question and Code Style Settings here:
To share Code Style Settings please navigate to Settings | Code Style | click on the gear near the Scheme field | Export... | Intellij IDEA code style XML.


Hello, thanks for taking the time to help me out.

Upload ID: 2024_02_20_rVuuRUgJSAzYoNUv2h65Xm



Hello Petros,

Thank you for the provided details. 
In the Settings | Editor | Code Style | HTML | Other menu there is the Wrap attributes drop-down menu. Please set it to Do not wrap and apply changes:

Is this what you were looking for?


Please sign in to leave a comment.