Cannot install or start Pycharm on macOS Monterrey 12.7.1


pycharm is not able to open or install after double click on MacOS Monterrey 12.7.1 (intel core i5)

I installed pycharm community version 2023.3.3 64. bits (intel version)

Why dosen't it open? is there a different version of pycharm that needs to be installed?



I just tried to install the toolbox app (intel version) and when I double click it, this one dosen't open

Also tried to open toolbox download with:

-Right click and click open. Nothing happens.

-Open with and then click DiskImageMounter. Nothing happens



Make sure that you have fully removed PyCharm from your Mac before reinstalling it. To do so, go to Finder -> Applications -> PyCharm, and drag the PyCharm icon to the Trash. Also, go to ~/Library/Preferences and remove the PyCharm folder.

f the issue persists, please provide us with the installation logs/ You can find the log files in the ~/Library/Logs folder. Please send us the PyCharm.log file

You can upload him to and share the uploadID


Please sign in to leave a comment.