Console spacing on macOS is incorrect sometimes

I don't understand what is causing it yet but I always experience an issue with the console font width being incorrect. It looks exactly like and 

It's worth noting that changing Editor > Color Scheme > Console Font > Font does nothing when this problem occurs. However, changing the font size does reflect in the console. :shrug:

I usually reset all of my settings, or reinstall to correct it. It's pretty frustrating.

1 comment

Hi Zach,

It could be

Have you tried changing the console font to a monospaced one? You can tick the ‘Show only monospaced fonts’ checkbox and then choose one of available monospaced fonts.

The other thing to try is switching your IDE runtime to the default JetBrains Runtime (JBR) in case something else is selected. It could be a Java rendering issue.


Please sign in to leave a comment.