Local CPU usage very high when using SSH

Hi,

DataSpell: 2023.3.4

MacOS: 14.3.1

I am using DataSpell over ssh (python is running on a remote linux server).  When doing training that produces a progress bar, the CPU usage on my LOCAL machine gets very high.  The fan on the local machine turns on.

The training is most definitely running remotely and using the remote GPU.

All I can imagine is that DataSpell is using all of that CPU to try and keep the progress bars updated?  Is there an easy way to lower how often they are updated?

Or perhaps it's something else?

Thank you

Dan

0
6 comments

Hello, Dehaplessdefeated. Please accept my apologies for the late reply. 


I am using DataSpell over ssh (python is running on a remote linux server).

Could you please describe your setup in more detail? Do you use the File | Remote Development… functionality?

0

I have a remote ssh profile setup which is where the jupyter notebook gets started.

I don't have a `File / Remote Development` option:

Remote python interpreter is selected:

Is there some other information I can help provide?

Dan

0

Dear Dant,

Thanks for your quick reply!

0

If your local CPU usage is very high when using SSH (Secure Shell), it could be due to a variety of reasons. Here are some potential causes and solutions:

1. **Background Processes**: Check if there are any background processes running on your local machine that might be consuming CPU resources. Use Task Manager on Windows or Activity Monitor on macOS to identify and terminate any unnecessary processes.

2. **SSH Client Configuration**: Review your SSH client configuration settings. Certain configurations, such as aggressive key exchange algorithms or encryption settings, can consume more CPU resources. Adjusting these settings to prioritize performance may help reduce CPU usage.

3. **Compression**: SSH supports data compression to reduce bandwidth usage, but this can increase CPU usage, especially on slower machines. Consider disabling compression in your SSH client configuration if performance is a concern.

4. **Large Data Transfer**: If you're transferring large amounts of data over SSH, such as copying files or running resource-intensive commands remotely, it can cause high CPU usage on both the local and remote machines. Optimize your data transfer methods or split large tasks into smaller chunks to reduce CPU load.

5. **SSH Server Configuration**: The SSH server configuration on the remote machine could also impact CPU usage. If you have access to the server configuration, consider optimizing it for performance or adjusting settings such as connection limits and authentication methods.

6. **Network Latency**: High network latency can sometimes cause increased CPU usage during SSH sessions, especially when dealing with interactive sessions or real-time data transfer. Check your network connection for any issues and consider using a wired connection instead of Wi-Fi for better performance.

7. **SSH Agent**: If you're using an SSH agent to manage authentication keys, it may be consuming CPU resources, especially if it's constantly polling for new keys or handling a large number of connections. Restarting the SSH agent or reducing the number of keys loaded into it may help.

8. **Update Software**: Make sure that both your SSH client and server software are up to date. Updates often include performance improvements and bug fixes that can help reduce CPU usage.

9. **Hardware Limitations**: If your local machine has limited CPU resources, such as an older or low-powered processor, it may struggle to handle SSH sessions efficiently. Consider upgrading your hardware if possible, or offloading CPU-intensive tasks to more powerful machines.

By addressing these potential causes and implementing the corresponding solutions, you should be able to reduce high CPU usage when using SSH on your local machine. If the issue persists, you may need to further investigate specific aspects of your SSH setup or seek assistance from a technical expert.

0

Hi,

Please note that this problem happens *only* when dong a long running operation that has a progress bar.  So while I appreciate the “troubleshooting ssh 101”, I don't think it applies here.

Thank you

Dan

0
Hello there, 
Could you please take a screenshot of the system monitor when the issue occurs and screenshots of Settings | Project | Python Interpreter and Settings | Languages & Frameworks | Jupyter | Jupyter Servers? 
Also, please collect DataSpell logs with Help | Collect Logs and Diagnostic Data, upload the archive here: https://uploads.services.jetbrains.com/, and tell us the upload ID so we can check internal records.
0

Please sign in to leave a comment.