Stop pycharm running tests after any file change

Pycharm auto runs my test after any change I do in my files (including blank lines!) and I cannot find a way to make it stop. 
I think at some point a clicked some auto-run button on the debug window but I can't find this button anymore.

Please help, this is driving me crazy!


PyCharm version: 2023.3.5 (Professional Edition)



I don't see the menu shown in the screenshot in the link. Instead I have a “Nothing here” floating window.


@a l, may I ask which version is in use?

On the latest 2024.1 version  you can disable it by Rerun Automatically button:



That's the button I once clicked on and can't find anymore. I use PyCharm version: 2023.3.5 (Professional Edition).
Will try to update to a newer version.


I updated pycharm to the latest version. The button is back and pycharm does not auto run anymore.
Thank you!


Please sign in to leave a comment.