intellij Idea very slow on large projects

Answered

I'm using Idea to study code of many projects. for example 

https://github.com/open-telemetry/opentelemetry-java-instrumentation

Idea doesn't handle this project very well, it becomes very slow, sometimes it takes a long time to open a package to see the classes,see image bellow.  ‘always select open file’ hardly works.

I know i can disable modules but then i can not browse the project as i want and can not always view classes i want to view.

I use a capable laptop Dell XPS 15, Idea has plenty of memory, i give it 15G memory.

Do you have a suggestion how to improve that?

 

 

 

0
3 comments

Hello,

I couldn't reproduce the issue on my side. Please provide information from “Help | About” (click on Copy and paste data here). Do you use any antivirus software? 

0

I'm not running antivirus, I'm using linux opensuse tumbleweed.

IntelliJ IDEA 2024.1.1 (Community Edition)
Build #IC-241.15989.150, built on April 29, 2024
Runtime version: 17.0.10+1-b1207.14 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 6.8.8-1-default
Kotlin analyzer version: 2.0.0-ij241.15989-9
GC: G1 Young Generation, G1 Old Generation
Memory: 15000M
Cores: 16
Registry:
 ide.browser.jcef.contextMenu.devTools.enabled=true
 ide.experimental.ui=true
 llm.generate.commit.summary=true
 markdown.open.vcs.log.link=true
Non-Bundled Plugins:
 PsiViewer (241.14494.158-EAP-SNAPSHOT)
 PythonCore (241.15989.150)
 com.github.b3er.idea.plugins.arc.browser (0.32)
 com.jetbrains.space (241.15989.9)
 Docker (241.15989.111)
 DevKit (241.15989.180)
 Lombook Plugin (241.15989.150)
 camtwoTomcatRunner (1.7)
 String Manipulation (9.13.0)
 io.intellij-sdk-thread-access (2.2.1)
 com.arcbees.plugin.idea (1.2.1)
 izhangzhihao.rainbow.brackets (2024.2.3-241)
 org.digma.intellij (2.0.331+241)
 com.intellij.ml.llm (241.15989.156)
 com.atlassian.bitbucket.references (2023.1.282)
 com.jetbrains.hackathon.indices.viewer (1.26)
 com.github.radgospodinov.plugin.reminder (0.6.4)
Kotlin: 241.15989.150-IJ
Current Desktop: GNOME
 

0

Please try to temporarily disable custom plugins ("Settings | Plugins - cog wheel - Disable all downloaded plugins"). Will it help?

0

Please sign in to leave a comment.