Code With Me: client can connect to host, but host shows "No one joined"


I'm a Mac user trying to host a Code With Me session with a colleague. We are able to start the client and see the shared code, but my host icon showed "No one joined". The client is initially read-only (in spite the host granting full access), but could edit after clicking "Request to edit files". The host could see the edits, but the client couldn't see my cursor, selection, etc. We tried it with both the lightweight installer via the shared link, as well as an IDEA trial version on the client side, but we still couldn't get it to work. Tried both Mac and Windows clients with the same results. Anyone else seen this? Any workarounds? I'd prefer to use IDEA for sharing if possible…


# host OS and IDEA versions
IntelliJ IDEA 2024.1.1 (Ultimate Edition)
Build #IU-241.15989.150, built on April 29, 2024
Licensed to __ / __
Subscription is active until December 18, 2024.
Runtime version: 17.0.10+1-b1207.14 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 14.4.1
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 12
Metal Rendering is ON
Non-Bundled Plugins:
 com.andrewbrookins.wrap_to_column (1.8.0)
 Pythonid (241.15989.166)
 R4Intellij (241.14494.158)
 net.ashald.envfile (3.4.2)
 ru.adelf.idea.dotenv (2024.1)
Kotlin: 241.15989.150-IJ

1 comment


Thank you for the feedback. Please reach us by support ticket to with logs collected from both IDEs (host and guest) within a problematic session. Please take a look at how to collect logs:



Please sign in to leave a comment.