How do you control the memory footprint of WebStorm

I've noticed the memory footprint of WebStorm with a large Angular project loaded is 10GB+  When I look at the processes running, I see a ton of NODE processes, but why?    This is the screenshot, I'm running Fedora 40, Gnome 46 on Wayland, and I can't imagine this makes any sense.

 

This screenshot shows the memory footprint is ~15 GB

Now the screenshot is an exception, but I normally see 10GB+, this is a more typical process list:

I have my memory limit set to 4GB, but apparently that limit doesn't actually impose to the running processes.  

 

0
3 comments

IDE can spawn different language services (Typescript, linters, tailwindcss,etc.) depending on your settings/plugins/project dependencies.

Please check the node command arguments in task manager to see what script is eating the memory.

 

0

Why?  What is Java needing for 4 GB+ of memory for if it can't contain the language services, and the linters?  It's launching processes but losing control of them, and then relaunching them.   The point of the IDE is to host the language services, which includes linters, spawning them off is crazy.

The bottom node entry ~730 MB is for the JavaScript language service.  The one at ~2.4 GB is the linter, and on top of that I still have to launch a web server to run the code. The 4 GB memory limit means nothing if it doesn't control the spawned processes.  

I'll grant you need to run the web server, so take that off the table, so the spawned process are taking almost as much memory as Java.  How do you strip everything out.  I've also turned off all plugins except for the linter.
 

0

The IDE needs to integrate with certain tools, such as the Typescript compiler or ESLint, which are JavaScript applications executed with node. Settings for java heap size can't affect node.js applications, they only control the Java memory usage. It is important to note that the IDE does not have control over the memory usage of these services, as they are third-party tools not developed by JetBrains. If needed, you have the option to disable the ESLint integration and the Typescript language service by navigating to Settings | Languages & Frameworks | JavaScript | Code Quality Tools | ESLint and Settings | Languages & Frameworks | TypeScript respectively.

Thank you for your understanding.

0

Please sign in to leave a comment.