Dropping Characters?


IntelliJ IDEA 2024.1.2 is dropping characters for me on macOS, as if it's lagging and has no keyboard buffer. I can type similar things in VSCode and no characters are lost.

Tried to open a support ticket with a screencast showing the issue, but the support system is already broken; getting “Uncaught TypeError: this.logDeflectionRateEvent” in multiple browsers (Safari, Edge).

I'm going to downgrade to 2024.1.1 to see if it goes back to normal.

Can you please upload the zipped log file and the screencast to https://uploads.services.jetbrains.com ?

Found this when googling for logDeflectionRateEvent, also having youtrack fail on that in the script “VM30 script.js”. 
Fixed it by running the following in the browser console, which let me open an issue when pressing the submit button:

To clarify, this is not related to the issue the thread is about, but the issue of not being able to submit a support ticket.


The screencast was already uploaded before I got the error trying to submit the issue:

Upload id: 2024_05_27_vFwmVpjNo6weaa1T7uhP7S (file: intellij-dropping-characters.mp4)

I'm currently using 2024.1.1, so the logs may not be useful right now – if I encounter the same problem after upgrading again, I can upload.

I could not reproduce the issue from my side. 

Does the same happen in other projects?

Can you please try to disable all the downloaded plugins(Settings | Plugins | Click the gear button | Disable all the downloaded plugins) and restart the IDE?

Please sign in to leave a comment.