Datatype changing issue (unsigned/signed datatype)


I have been using DataGrip for a few months right now and I have been encountered several issues regarding to the uploading files function. 

1. Before uploading a file into my database, I always check  datatypes that were assigned to columns. Datagrip does not always assign the right type. Especially when it comes to date/datetime etc. It always recognises it as a text value. I have managed to deal with this issue by using MYSQL command (str_to_date) etc. 

I have tried to change datatype in DDL preview before uploading a file many many times but DATAGRIP NEVER applies my changes and always assigns what it thinks is most suitable aka what I see in DDL preview. 

I would like to know the solution to it. because it is really annoying. 


2. Constant issue with data range: Data truncation: Out of range value for column. 

(I tried to change datatype in DDL preview. It doesnt work) 

   It happens every time I load big files. I have read that it can happen because of an unsigned/signed datatype. And my guess is that an unsinged datatype is used in DATAGRIP. I checked the settings and found nothing about singed/unsigned datatype. 

Where I can change it? Because of this issue, I can not work with big files, only small ones,  and I feel like that DATAGRIP was not designed for big files. (according to my experience) 

I will appreciate your help

Thank you in advance. 


Please create a new bug report on YouTrack with the step by step to reproduce it -


Is the second  error specifically to DataGrip only or you can reproduce it as well on MySQL CLI? Looks like it might be related to the size of  a  particular column's data type


1.I have tried to post an issue on youtrack. It does not allow; it keeps saying, “Can not find variable: I.” This is why I posted here. 

2. Yes. It is related to the size of a column. And I have read that it can happen because of an unsinged/ signed datatype which I was asking about. (It is also mentioned in the post which link you have posted above) 

Where I can find settings in DataGrip to change the datatype to a singed one? Because it seems to me that now DataGrip uses unsigned datatypes. 


Please sign in to leave a comment.