No module named via docker interpreter

So I can't find solution for loading all packaes/modules from the docker container.
P.S. As you can see in container there are a lot more packages, e.g. requests exists in container, but pycharm doesn't see it :(
Maybe someone faced with such issue?


Hi Pavel Televich , have you tried File | Invalidate Caches | Invalidate and restart? Does it help in any way? 

If not, would you please share logs from Help | Collect Logs and Diagnostic Data? Please upload it to and let me know the upload ID.


Hi Mikhail Tarabrikov , thanks for quick respond and support! It works, but with nuances. Will describe in details for saving time other developers!
I tried invalidate cache before created this post (a couple days ago)  and it didn't work. But in the date range of creating this post and your answer I've rebuilt docker containers. So, now when I've invalidated cache once again packages have appeared in the pyCharm package list. But one package which I've created manually in the container still hadn't shown. It was the answer for me how this feature works. So I rebuilt docker container and invalidated cache once again and all packages became visible in the list. 
Thanks a lot for the Help once again! Cheers!

P.S. It's not comfortable to restart contain and invalidate cache every time I add a new package manually. Would be perfect and very useful, if pyCharm read `pip list` from docker container and add dynamically! 


Please sign in to leave a comment.