Pycharm won't recognize Python 3.5 Interpreter path in Windows 10


I have run into a frustrating Pycharm Community Edition (2016.2.3) installation problem on my Windows 10 PC. Prior to installing Pycharm, I installed both Python 2.7 and 3.5 interpreters from In both cases I chose the default installation options. Pycharm recognizes the path for the 2.7 interpreter but not 3.5. I found that the 3.5 python.exe file is installed in a sub-folder of C:\Users\Me\Appdata. However, Appdata is a hidden folder in Windows, and when I navigate to Pycharm >> configure >>settings >>Project Interpreter menu options and then choose "Add Local", Pycharm will not show the Appdata folder in the directory structure, apparently because it is hidden.

Other than changing the attributes of the Appdata folder (unhiding), which I don't want to do due to risk of other problems, how do I solve this problem?




Ah, I found the answer! In the pop-up dialog box to configure the interpreter, there is an icon on the toolbar to show hidden files. Once clicked, I was able to navigate to Appdata directory and then sub-directories. Kind of bad software design, in my opinion, to have that "show hidden files/folders" option turned off by default given the default Python 3.x interpreter installation location (in a sub-directory of a hidden folder).


There's also another way to do this. You can drag and drop the python.exe file from Windows File Explorer to the Select Python Interpreter window. This will automatically add the hidden path. Not sure however if this option is available in all PyCharm versions. I'm using the latest version as of this date (Community 2020.2.1). Just did this today to add Python 3.8.5 interpreter to my existing PyCharm environment.


Dang, showing hidden files didn't work for me and neither did the dragging.


Please sign in to leave a comment.