IntelliJ User Interface rendering issue


Hi There,

I'm having a problem with the user interface, it is not rendering correctly (see image)

This is just a small demonstration, when I open the code all the user interface is messed up, specially around the tabs

Can anyone tell what the problem is?

My environment:
- Windows 10|
- IntelliJ ultimate, Version 2016.2.4


Comment actions Permalink

Hi Serge,

I tried your solution, none of it worked, however one of your links gave me a clue, so, thanks for that :-) I found a solution (which would be valid only for my particular case) and put it here just in case someone else find it useful:

I changed the JDK that Intellij uses to run for the Oracle's one:

  • Install the last version of Oracle's JDK (in my case: 8u102)
  • Set the environment variable IDEA_JDK to the path to this JDK
  • Run Idea using idea64.exe instead of idea.exe (I work on a 64bit machine)

I'm not sure what the problem was, my theory is that OpenJDK uses different native libraries to render Swing than Oracle's JDK, but this was true for previous versions of the JDK, not sure about 1.8.


Comment actions Permalink

Can't reproduce, works fine with both Oracle and JetBrains runtimes here.


Please sign in to leave a comment.