10 comments
Comment actions Permalink

Ah, looks like they have one on their site.


Amazingly, google turned up nothing!

I will give it a try :)

0
Comment actions Permalink

OK, no luck, even saving the sample file they gave in the PHPStorm cosestyles folder, and using the existing eslint file:

{
"extends": ["standard"],
"parser": "babel-eslint",
"globals": {
"_": false,
"define": false,
"app": true,
"Parse": false
}
}

Any ideas?

I have a scrollbar full of red and gold

0
Comment actions Permalink

OK, I feel like I've exhausted all the options.

Any line without a semicolon is being complained about. I've turned JSLint off as well, which hasn't appeared to do anything.

Do I just not understand how this works?

EDIT. I finally found this, and suppressed the inspections:

Is this the way to do it? Or do I still not really understand the role that the different components play?

0
Comment actions Permalink

You did it right. Errors that come from PhpStorm own inspections should be suppressed per instructions in https://www.jetbrains.com/help/phpstorm/2016.2/suppressing-inspections.html#d1001672e65.

Those that come from ESLint normally have 'ESLint:' prefix. To suppress them, you have to edit your ESlint config accordingly

0
Comment actions Permalink

Thanks for the input Elena, hopefully I appreciate the difference now!

0
Comment actions Permalink

Argh... Elena, I don't understand this.

I've just opened up a *different* project I was working on just yesterday, and it's now all 2-space Standard JS formatting! :(

I've managed to track it down to the preference "Detect and use existing file indents for editing" which when turned off, everything goes back to how it was.

I don't understand why it's doing this though?

It's a different project, and even more weirdly, even when it looks like it has updated the indents, the version control markers don't show to say the file has changed.

Can you explain the voodoo!?

Thanks :)

 

0
Comment actions Permalink

Sounds strange... "Detect and use existing file indents for editing"  doesn't affect formatting - when it's on,  existing indents are used for editing ( i.e new line is indented according to current file indents when you hit Enter), but they are not respected when you invoke Code/Reformat Code - file is formatted according to code style preferences. So I don't understand what you are talking about... if you see that all your files have indentation set to 2 spaces, it has no relation to "Detect and use existing file indents for editing" - it just means that they have been formatted using 2 spaces indent

0
Comment actions Permalink

It must be a bug then, because when I posted that post, I could toggle that checkbox and hit Apply, and all my open files would update their indentation levels from 2 spaces to 4-space tabs and back again, however many times I toggled.

I just tried the same again, and no effect, so I'm just as confused as you at this moment!

 

0
Comment actions Permalink

haven't heard of such issues - this option can't affect current files formatting. Should you find a way to recreate it, please let me know

0
Comment actions Permalink

Thanks Elena I will.

I'm 99% sure I'm not going crazy, and this is what happened!

I suspect it has something to do with setting up a new project configuration, so won't be seen 99.999% of the time.

0

Please sign in to leave a comment.