Bottom horizontal scrollbar disappears and won't show back up on Mac

In the main code editor the horizontal scrollbar on the bottom disappears after a few seconds and won't show up even when I hover my mouse over where it use to be. The scrollbar shows up with I scroll left and right using the trackpad.

My setup: Macbook Pro with an external mouse and keyboard.

18 comments
Comment actions Permalink

I have just installed WebStorm on Mac and have the same problem. There is no horizontal scrollbar and no setting to show/hide it. It occasionally appears momentarily and then vanishes again.

0
Comment actions Permalink

What WebStorm version do you use? See my comment above

0
Comment actions Permalink

I'm not aware of such version... As I have mentioned, the issue is fixed in 2016.3 EAP - did you try it?

0
Comment actions Permalink

I'm sorry, it was 2016.2.4. I'll try to find 2016.3.

0
Comment actions Permalink

That seems to have corrected the problem. Thanks

0
Comment actions Permalink

I don't have any horizontal scrollbars in IntelliJ 2016.3 (Mac OS 10.11.6, JRE 1.8.112)

0
Comment actions Permalink

What is "Show scroll bars" option value in System Preferences / General? Try setting them to "Always" - does it help? See https://youtrack.jetbrains.com/issue/IDEA-162269#comment=27-1645150

2
Comment actions Permalink

Ah, now I understand.

The thing is, I wouldn't mind hidden scrollbars, but on my mouse I don't have horizontal scrolling. I have to drag the bars - and in IntelliJ, they don't even appear when I move the mouse to where they should show up.

0
Comment actions Permalink

I also have a MBP that I use with an external mouse and keyboard. I use RubyMine 2017.1.3. I often have long lines of SQL in my console and there is no horizontal scrollbar. The vertical scrollbar does appear. I don't want to change the System Preferences to "Always" for the whole mac, but even when I do it doesn't work - I still don't see a horizontal scrollbar when there are long lines.

As a second best, if I had a Preference in Editor / Console to "wrap long lines" then at least I could see the text of the line without scrolling.

0
Comment actions Permalink

>As a second best, if I had a Preference in Editor / Console to "wrap long lines" then at least I could see the text of the line without scrolling.

 

Did you try enabling soft wraps? In Settings | Editor | General, turn Use soft wraps in editor on, and enable Use soft wraps in console in Settings | Editor | General | Console

2
Comment actions Permalink

Hi Elena, yes I have tried that and it's ok, but I find it hard to find what I'm looking for. I would prefer one line per console output and scroll to the right when it's one I care about. The Event Log next to the console on the bottom has exactly the behavior I want. No scrollbar unless the output is wide, then the scrollbar appears. So clearly it's possible, it's not a Mac thing.

0
Comment actions Permalink

I am using 

IntelliJ IDEA 2017.2.5
Build #IU-172.4343.14, built on September 25, 2017
JRE: 1.8.0_152-release-915-b12 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.4

and I am having the same problem. The bottom scrollbar disappears and does not come back unless I hold down the left mouse button and drag across the screen to the edge. Can we get this fixed so the scrollbar appears when you mouse over the area?

I don't see option to enable them always. Was this removed in a recent version?

1
Comment actions Permalink

Same problem here 

1
Comment actions Permalink

<del>This still occurs. Occasianally I can also lose the cursor but switching Spaces seems to force a refresh/redraw and I can see the cursor again.</del>

Not sure this is a bug after all. Updating my OS configuration resolved my issue. See https://youtrack.jetbrains.com/issue/IDEA-162269

0
Comment actions Permalink

Just noting that I'm on version 2018.2.3 and just had this problem happen to me. I don't see any different circumstances than just opening a file from a Find in Path search results list, and the file looks normal with lines going down beyond the viewport and characters going off the right side (I don't use word-wrap in code).

0

Please sign in to leave a comment.